Skip to main content

Cannot overwrite images in a Knowledge Articles (Update them or Adding an Image with Same Name)

Issue

If the image already exists in the Image Library, and you are attempting to reupload a change to the same image by opening an article, clicking on the image, and then clicking on the insert image icon in the WYSIWYG, then an error will come up saying that you cannot overwrite the existing image. Whenever attempting to add an image to an article, a pop up advises that the there is already an image by this name, and to choose a different name.

Cause

An image with the name already exists within ServiceNow, and therefore, the image cannot be added with the same name.  The only way to update the image is to delete the existing image and upload it again.